[libvirt-users] vm live storage migration failure.

Edward Young edward.and.young at gmail.com
Tue Mar 10 20:50:08 UTC 2015

Hi all,

When I migrate a live vm with two virtual disk images from one node to
another. Bothe of the nodes are in the same LAN and there is no shared

I run the following command and get the output blew:

yyang at node1:~$ sudo virsh migrate --live --persistent --copy-storage-all
--unsafe --verbose vm1 qemu+ssh://

root at's password:

root at's password:

root at's password:

error: Cannot recv data: Permission denied, please try again.

Permission denied, please try again.

Permission denied (publickey,password).: Connection reset by peer

I'm sure the root passwd I entered is correct. And When I run the following
command, it works. I can use qemu+ssh to connect to a remote libvirtd

yyang at node2:~$ sudo virsh

Welcome to virsh, the virtualization interactive terminal.

Type:  'help' for help with commands

       'quit' to quit

virsh # connect qemu+ssh://

root at's password:

virsh # list

 Id    Name                           State


 6     vm1                            running

 7     vm2                            running

virsh #

Any suggestions about this issue?

Thanks a lot!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/libvirt-users/attachments/20150310/9da8f3a4/attachment.htm>

More information about the libvirt-users mailing list