[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt-users] Blockcommit error



On 05/21/2015 04:31 PM, Mathew Moon wrote:
> HI,
> 
> I am receiving the following error when I try to run blockcommit:
> ==============================================================
> root farnsworth:/var/lib/libvirt/images# virsh blockcommit pg94-test vda
> --top /var/lib/libvirt/images/pg94-test.snap4 --active --pivot --verbose
> error: unsupported flags (0x4) in function qemuDomainBlockCommit

That probably  means your version of virsh is newer than your version of
libvirtd (virsh was new enough to know how to request the flag, but
libvirtd was too old to support the flag).  To confirm, can you do:

virsh version --daemon

and if the 'Using library:' line is newer than the 'Running against
daemon:' line, I'm right.

-- 
Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]