[libvirt-users] GPU passthrough failed to find romfile

David Hlacik david at hlacik.eu
Sun Feb 7 16:59:24 UTC 2016

Hello guys,

this drives me insane. I am trying to pass romfile of my GPU for UEFI boot

This is an error I am getting :

[root at brutus-coreos opt]# virsh start winos1
error: Failed to start domain winos1
error: internal error: early end of file from monitor: possible problem:
2016-02-07T16:56:09.358285Z qemu-system-x86_64: -device
failed to find romfile "/opt/MSI.R9380.4096.150713.

The file is there , even owned by qemu

[root at brutus-coreos opt]# cd /opt
[root at brutus-coreos opt]# ls -lsa
total 136
  4 drwxr-xr-x.  2 root root   4096 Feb  7 17:53 .
  4 dr-xr-xr-x. 18 root root   4096 Feb  4 18:58 ..
128 -rw-rw-r--.  1 qemu qemu 131072 Feb  7 17:53 MSI.R9380.4096.150713.rom

I have tried to put it into /var/lib/libvirt/images or /usr/share/qemu ,
but it ends with the same error.

This is my libvirt XML

[david at brutus-coreos ~]$ sudo virsh dumpxml winos1
[sudo] password for david:
<domain type='kvm'>
  <memory unit='KiB'>15360000</memory>
  <currentMemory unit='KiB'>15360000</currentMemory>
  <vcpu placement='static'>8</vcpu>
    <type arch='x86_64' machine='pc-i440fx-2.4'>hvm</type>
    <loader readonly='yes'
    <boot dev='hd'/>
      <relaxed state='on'/>
      <vapic state='on'/>
      <spinlocks state='on' retries='8191'/>
    <vmport state='off'/>
  <cpu mode='host-passthrough'>
    <topology sockets='1' cores='4' threads='2'/>
  <clock offset='localtime'>
    <timer name='rtc' tickpolicy='catchup'/>
    <timer name='pit' tickpolicy='delay'/>
    <timer name='hpet' present='no'/>
    <timer name='hypervclock' present='yes'/>
    <suspend-to-mem enabled='no'/>
    <suspend-to-disk enabled='no'/>
    <disk type='file' device='disk'>
      <driver name='qemu' type='raw'/>
      <source file='/dev/ssd/winos1'/>
      <target dev='vda' bus='virtio'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05'
    <disk type='file' device='disk'>
      <driver name='qemu' type='raw'/>
      <source file='/dev/hdd/windata1'/>
      <target dev='vdb' bus='virtio'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x0d'
    <controller type='usb' index='0' model='nec-xhci'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x03'
    <controller type='sata' index='0'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x04'
    <controller type='pci' index='0' model='pci-root'/>
    <controller type='virtio-serial' index='0'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x0b'
    <interface type='direct'>
      <mac address='52:54:00:31:bc:b8'/>
      <source dev='enp0s31f6' mode='bridge'/>
      <model type='virtio'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02'
    <hostdev mode='subsystem' type='pci' managed='yes'>
        <address domain='0x0000' bus='0x01' slot='0x00' function='0x0'/>
      <rom file='/opt/MSI.R9380.4096.150713.rom'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x06'
    <hostdev mode='subsystem' type='pci' managed='yes'>
        <address domain='0x0000' bus='0x01' slot='0x00' function='0x1'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x07'
    <hostdev mode='subsystem' type='pci' managed='yes'>
        <address domain='0x0000' bus='0x00' slot='0x14' function='0x0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x08'
    <hostdev mode='subsystem' type='pci' managed='yes'>
        <address domain='0x0000' bus='0x03' slot='0x00' function='0x0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x09'
    <memballoon model='virtio'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x0a'
    <rng model='virtio'>
      <backend model='random'>/dev/random</backend>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x0c'
      <address type='isa' iobase='0x505'/>

Any help would be appreciated

David Hlacik

+420-777-307-745 | david at hlacik.cz

[image: View David Hlacik's profile on LinkedIn]
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/libvirt-users/attachments/20160207/c29f45f8/attachment.htm>

More information about the libvirt-users mailing list