[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt-users] virt-install errors and help sought



Narahari Lakshminarayana wrote:
> Friends:
> 
> I need some help and guidance from you regarding this virt-install issue
> I am seeing.
> 
> OS : SuseEnterpriseLinuxServer (SLES) 12 Service Pack 1
> virt-install version on the box
> virtual SLES12-bare:~> virt-install --version
> 1.2.1
> 
> libvirt version : libvirt-1.3.4-565.1.x86_64

SLES12 SP1 has libvirt 1.2.18. Do you have an openSUSE build service development
repo configured? Where did you get libvirt 1.3.4 for SLES12 SP1?

> 
> What I tried:
> =========
> 
> I tried to start virt-install as regular user and I am seeing errors
> listed below.
> 
> If I start the same with sudo it works (the user virtual shown here is a
> sudo enabled user)
> 
> I really want to start the virt-install as a regular user.
> 
> Please help.
> 
> Error
> ====
> 
> -----------------------------------------------------------------------------------------------------------------------------
> virtual SLES12-bare:~> virt-install --connect qemu:///session -n
> SLES12_SP1 --memory 4096 --vcpus 2 --cdrom
> /data/ADP_x86_64_SLES12SP1.x86_64-12.1.6.preload.iso --graphics spice
> --disk /data/kvm_images/SLES12_SP1.img
> WARNING  Graphics requested but DISPLAY is not set. Not running virt-viewer.
> WARNING  No console to launch for the guest, defaulting to --wait -1
> 
> Starting install...
> ERROR    Failed to connect socket to
> '/run/user/500/libvirt/virtlogd-sock': No such file or directory

Looks like a session instance of virtlogd is not running.

BTW, have you tried the latest libvirt 1.2.18 that is available for SLES12 SP1?
1.2.18 is the supported version in SLES12 SP1 and enjoys more testing than
arbitrary later versions.

Regards,
Jim


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]