[libvirt-users] problem with disk virtio driver

Andrei Perietanu andrei.perietanu at klastelecom.com
Wed Oct 5 11:13:38 UTC 2016

I just ran into a problem I can't make heads or tails of, so I'm hoping to
get some help here.

I have a custom built Embedded Linux running qemu-kvm  1.1.2 and libvirt

I'm creating a domain with the following config:

<domain type='kvm'>
  <memory unit='KiB'>2097152</memory>
  <vcpu placement='static'>2</vcpu>
    <type arch='x86_64'>hvm</type>
    <boot dev='hd'/>
    <boot dev='cdrom'/>
  <cpu mode='host-model'/>
  <clock offset='utc'>
    <timer name='rtc' tickpolicy='catchup'/>
    <timer name='pit' tickpolicy='delay'/>
    <timer name='hpet' present='no'/>
    <disk type='file' device='cdrom'>
      <driver name='qemu' type='raw'/>
      <target dev='hdb' bus='ide'/>
      <source file='custom.iso'/>

    <disk type='file' device='disk'>
      <driver name='qemu' type='qcow2'/>
      <source file='/path/to/vdisk.img'/>
      <target dev='vda' bus='virtio'/>
    <controller type='pci' model='pci-root'/>
    <controller type='usb'/>
    <controller type='ide'/>
   <interface type='bridge'>
      <source bridge='virbr0'/>
      <model type='virtio'/>

    <serial type='pty'>
      <target port='0'/>
    <console type='pty'>
      <target type='serial' port='0'/>
    <input type='tablet' bus='usb'/>
    <input type='mouse' bus='ps2'/>
    <input type='keyboard' bus='ps2'/>
    <graphics type='vnc' port='-1' autoport='yes'/>
      <model type='qxl' ram='65536' vram='65536' vgamem='16384' heads='1'/>
    <watchdog model='i6300esb' action='reset'/>
    <memballoon model='none'/>

Granted the OS I'm installing is again a custom Linux with some software
running on top ..so It's not a well known OS...but I'm hoping that does not
matter much.
After installation I get all sorts of kernel panics and errors about
services not being able to start.

So I tried the same thing on ubuntu 14.04.2 LTS which installed qemu-kvm
2.0.0 and libvirt 1.2.2

Same config xml, but this time it worked better -I was not getting the
kernel panics.
The OS I'm installing does not support IDE disks, it needs a virtio disk.

The obvious solution here would be to try and get a newer version of qemu,
but since we're talking about a custom built Linux I'd have to add the
package manually and compile from source...which cakes a long time to do.
So before attempting that....just wondering....is there a better way?
Anything I can try?



The information transmitted is intended only for the person or entity to 
which it is addressed and may contain confidential and/or privileged 
material. Any review, retransmission, dissemination or other use of or 
taking of any action in reliance upon this information by persons or 
entities other than the intended recipient is prohibited. If you receive 
this in error please contact the sender and delete the material from any 
computer immediately. It is the policy of Klas  Limited to disavow the 
sending of offensive material and should you consider that the material 
contained in the message is offensive you should contact the sender 
immediately and also your I.T. Manager.

Klas Telecom Inc., a Virginia Corporation with offices at 1101 30th St. NW, 
Washington, DC 20007.

Klas Limited (Company Number 163303) trading as Klas Telecom, an Irish 
Limited Liability Company, with its registered office at Fourth Floor, One 
Kilmainham Square, Inchicore Road, Kilmainham, Dublin 8, Ireland.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/libvirt-users/attachments/20161005/a310f90f/attachment.htm>

More information about the libvirt-users mailing list