[libvirt-users] migrated RHEL7/CentsOS7 VMs fail to boot

Daniel Pocock daniel at pocock.pro
Mon Apr 3 08:41:06 UTC 2017

On 20/03/17 15:02, Martin Kletzander wrote:
> On Mon, Mar 20, 2017 at 10:18:35AM +0100, Daniel Pocock wrote:
>> I migrated a CentOS7 VM (the fedrtc.org site) from an XCP
>> environment to a libvirt/KVM environment.
>> This involved using qemu-img to convert the image from VHD to
>> qcow2 and then using virt-install --import to define the VM in
>> libvirt.
> I have little to no idea how to help with the rest, but have you
> tried using virt-v2v for the switch?  It could help you a lot with
> some of these things.  I hope your use case is supported, I haven't
> really had many use cases for if myself.

All my test migrations had worked successfully with "virt-install
--import ..." so I never looked into virt-v2v.  Thanks for pointing
this out though.

Nonetheless, is there a reason the RHEL/CentOS VM requires the dracut
command to be run but the Debian/Ubuntu VMs don't need
update-initramfs to be run?  Should I open a bug or feature request
against dracut to make this easier, or has it been discussed previously?



More information about the libvirt-users mailing list