[libvirt-users] libvirtd segfault when using oVirt 4.1 with graphic console - CentOS7.3

Pavel Hrdina phrdina at redhat.com
Thu Apr 20 14:44:13 UTC 2017

On Thu, Apr 20, 2017 at 07:36:42AM +0200, Rafał Wojciechowski wrote:
> hello,
> I am getting such error:
> libvirtd[27218]: segfault at 0 ip 00007f4940725721 sp 00007f4930711740 
> error 4 in libvirt.so.0.2000.0[7f4940678000+353000]
> when I am trying to start VM with graphic spice/vnc console - in 
> headless mode(without graphic console) it is running
> I noticed this after update oVirt 4.0 to oVirt 4.1 however I noticed 
> that also libvirtd and related packages were upgraded from 1.2.7 to 2.0.0:
> libvirt-daemon-kvm-2.0.0-10.el7_3.5.x86_64
> libvirt-daemon-driver-qemu-2.0.0-10.el7_3.5.x86_64
> I am running up to date CentOS7.3 with 3.10.0-514.16.1.el7.x86_64
> I have same issue with SELinux and without SELinux(checked after reboot 
> with permissive mode)
> I tried to get information about this issue from oVirt team, but after 
> mail conversation both me and oVirt team thinks that it might be issue 
> in libvirtd
> in below link I am putting xmls generated by vdsm which are passing to 
> the libvirtd to run the VMs
> first one is from vdsm log and second one is extracted from dump after 
> segfault of libvirtd
> https://paste.fedoraproject.org/paste/eqpe8Byu2l-3SRdXc6LTLl5M1UNdIGYhyRLivL9gydE=


could you please provide core backtrace? I've tried to reproduce it on
CentOS 7.3 with the same graphics configuration but the guest started
and there was no segfault.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: Digital signature
URL: <http://listman.redhat.com/archives/libvirt-users/attachments/20170420/9039173c/attachment.sig>

More information about the libvirt-users mailing list