[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt-users] LIBVIRT-4.6.0 can't work with QEMU 3.0.0



On Wed, Aug 08, 2018 at 10:06:12 +0100, Daniel Berrange wrote:
> On Wed, Aug 08, 2018 at 10:58:50AM +0200, Holger Schranz wrote:
> 
> > checking for JANSSON... no
> 
> This is the problem. In 4.6.0 we just switched to using JANSSOn instead
> of yajl for JSON parsing. Your host doesn't have the development headers
> installed for jansson....
> 
> 
> > configure: 
> > configure: Configuration summary
> > configure: =====================
> > configure: 
> > configure: Drivers
> > configure: 
> > configure:       QEMU: no
> 
> so the QEMU driver was not built. 
> 
> There's a bunch of other "no" in the summary below you should consider
> whether you need any of them,

This is most probably caused by not having the 'jansson' library
installed.

[...]

> > configure:    jansson: no

The new approach is to disable the qemu driver if we don't have JSON
support since it would not work with qemu anyways.

Attachment: signature.asc
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]