[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt-users] Mount URL as cdrom/iso KVM/QEMU



On Thu, Aug 09, 2018 at 10:50:46AM +0000, Inception Hosting wrote:
> Just a quick correction and apologies, the actual issue is that http
> will not work, https will so I dont think this is a bug as such I
> think this is by design likely for security.
> 
> 
> Looking at the man page for qemu-kvm it states http will work with
> examples given however only https works, my best guess from looking
> at the spec file from the srpm is that it has only been enabled in
> the centos qemu-kvm-ev with https:

Yes, the qemu RPMs in centos & RHEL have disabled support for http://
protocol, however, I expect that to immediately fail when trying to
start the guest. eg

# /usr/libexec/qemu-kvm  -drive file=http://example.com/foo/bar -accel tcg
qemu-kvm: -drive file=http://example.com/foo/bar: Driver 'http' is not whitelisted

so I'm puzzelled why your guest successfully started at all with a
http protocol in use.

Are you able to share your QEMU log from /var/log/libvirt/qemu/$GUESTNAME.log
from a VM that fails to launch with http ?

Regards,
Daniel
-- 
|: https://berrange.com      -o-    https://www.flickr.com/photos/dberrange :|
|: https://libvirt.org         -o-            https://fstop138.berrange.com :|
|: https://entangle-photo.org    -o-    https://www.instagram.com/dberrange :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]