[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt-users] How to change the default connection of 'virsh' tool from 'qemu' to 'xen' ?



On Wed, 2018-10-31 at 10:56 +0900, Minjun Hong wrote:
> Hi.
> 
> Thanks to help of this mailing list (especially Jim Fehlig), I have finished setup of libvirt.
> However, there is something weird. It is that I installed libvirt on 5 servers but 
> the default connection of one of them is 'qemu:///' even if those of the others are all 'xen:///'.

You probably installed the QEMU driver on that one server only: if
that's indeed the case, the easiest way to fix the inconsistency
would be to uninstall it.

If that fails...

> I searched how to change it but, I only found a bypass adding " LIBVIRT_DEFAULT_URI='xen:///' " in my .bashrc file.
> Currently, value of the variable (LIBVIRT_DEFAULT_URI) is set to 'qemu:///'.
> Since the bypass makes the virtualization type of the server visible 'qemu' to the open stack, I have to change libvirt configuration.
> 
> I also checked some configure files under '/etc/libvirt', such as libvirt.conf, libvirtd.conf and libxl.conf.
> But I have no idea, how and what to change.
> Please give me some advise. It will be a big help for me.

... you can simply set

  uri_default = "xen:///"

in /etc/libvirt/libvirt.conf to change the system-wide default URI
without having to mess with environment variables.

-- 
Andrea Bolognani / Red Hat / Virtualization


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]