[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt-users] CGroup V2 Support



On Sun, Apr 07, 2019 at 06:46:19PM +0900, ITeng A wrote:
> Dear all
> 
> Does the current version of libvirt support the new cgroup v2 ?
>  I am running KVM qemu VMs on Ubuntu with linux Kernel 4.18 with cgroup v1
> and I would like to use Cgroup v2  but we I mount cgroup v2  the  libvirt
> virtualization daemon  fail to start with error message that it cant create
> cgroup  /system.slice/libvirtd.service  no such file or directory.
>

Hi Asraa,

Cgroups V2 is supported since libvirt 4.9.0 for cpu, cpuacct, io, memory
controllers.

In libvirt 5.2.0 we added support for cpuset with kernel 5.0.

There is still no support for devices controller but that one is not
mandatory to run KVM/QEMU VMs as there is a bug in kernel that leaks
some resources.

Pavel

Attachment: signature.asc
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]