[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt-users] Error connecting to hypervisor



On Sat, 27 Apr 2019 at 12:53, Michal Prívozník <mprivozn redhat com> wrote:
>
> On 4/23/19 11:56 PM, Sukrit Bhatnagar wrote:
> > Hi,
> >
> > I have compiled and installed libvirt from git checkout
> > and started libvirtd service. The version is 5.3.0 and
> > I have done system-wide installation.
> >
> > When I do a `virsh list`, I get the following error:
> > error: failed to connect to the hypervisor
> > error: Unable to encode message header
>
> This is very suspicious. The error is reported because the function that
> is generated by rpcgen and supposed to encode messages failed. Looks
> like rpcgen generated some unusable code? What's your rpcgen? I have
>
> glibc-rpcgen-2.26.9000-41.fc28.x86_64
>
> and everything's working for me. BTW if you try compiling from 5.2.0
> tarball the error should go away because we ship generated sources in there.

I am using Fedora 29 and glibc-rpcgen is not available.
I have these packages installed for rpc:
rpcgen-1.4-1.fc29.x86_64 (rpcsvc-proto)
libtirpc-1.1.4-2.rc2.fc29.x86_64
libtirpc-devel-1.1.4-2.rc2.fc29.x86_64

I have tried using libvirt 5.2.0 form tarball but the same error is there.

> Michal


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]