[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt-users] X11 apps on lxc



On Fri, Oct 18, 2019 at 07:12:23PM +0000, Jesus wrote:
> Hi
> How can I run X11 apps on the local X11 using libvirt lxc?
> I already had this runing on centos 7 but I upgraded to centos 8 (I rebuild libvirt) and the socket is not in the /tmp/.X11-unix/ folder of the vm any more.
> Can somebody help with this?

It may well have moved into the abstract namespace and thus not be visible
in the filesystem.

If I run strace I see apps connecting  @/tmp/.X11-unix/X0 first, and only
if that doesn't exist, does the client try /tmp/.X11-unix/X0. The leading
'@' indicates a NUL character requesting the abstract namespace.

If /tmp/.X11-unix doesn't exist at all its possibly only listening on the
abstract namespace, and not the normal namespace. There should be CLI
args to change this behaviour when starting your X11 server.

See more at:

  https://tstarling.com/blog/2016/06/x11-security-isolation/

Regards,
Daniel
-- 
|: https://berrange.com      -o-    https://www.flickr.com/photos/dberrange :|
|: https://libvirt.org         -o-            https://fstop138.berrange.com :|
|: https://entangle-photo.org    -o-    https://www.instagram.com/dberrange :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]