[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Xen: libvirt.libvirtError: An error occurred, but the cause is unknown



On 4/7/21 3:25 AM, Mathieu Tarral wrote:
I enabled the log output in libvirt daemon, and there was one error message that appeared:

error : libxlMakeDomBuildInfo:553 : unsupported configuration: emulator '/usr/lib/xen-4.11/bin/qemu-system-i386' not found

libxlMakeDomBuildInfo reports the error via virReportError

https://gitlab.com/libvirt/libvirt/-/blob/master/src/libxl/libxl_conf.c#L592

When searching the path with apt-file, there are no packages providing this file.

I have qemu-system-x86-xen however:
https://ubuntu.pkgs.org/20.04/ubuntu-universe-amd64/qemu-system-x86-xen_4.2-3ubuntu6_amd64.deb.html

which provides /usr/bin/qemu-system-i386

Creating a symlink solved my issue:
cd /usr/lib/xen-4.11/bin
sudo ln -s /usr/bin/qemu-system-i386 .

-> This seems to be an opened bug report on the libvirt Debian package (since 2016 !)
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=830307

-> Is there a way for libvirt to actually report meaningful errors in this case ?

A meaningful error is reported, it's just not making it back to the client. And I don't spot anywhere along the failure path of libxlDomainCreateWithFlags -> libxlDomainStartNew -> libxlDomainStart -> libxlMakeDomBuildInfo where that helpful error would be unset/overwritten.

Regards,
Jim


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]