[Linux-cluster] segment fault

hv hv at trust-mart.com
Fri Jun 25 10:07:07 UTC 2004

      I got a segment fault when I run acucobol on a gfs filesystem.My system is redhat AS3,kernel is 2.6.7. The LVM2,GFS all are from CVS.My host is Dell 6650,EMC CX200.
      When I run vutil or runcbl on these GFS file system,This oops is appear:
      <1>Unable to handle kernel paging request at virtual address 0100003c
 printing eip:
*pde = 256d0001
Oops: 0002 [#2]
Modules linked in: qla2300 qla2xxx scsi_transport_fc
CPU:    6
EIP:    0060:[<c02a9ddc>]    Not tainted
EFLAGS: 00010286   (2.6.7-bk7)
EIP is at find_lock_by_id+0x6/0x1d
eax: 0100003c   ebx: 01000004   ecx: 00000137   edx: 010d02ac
esi: f7dfcf6c   edi: ffffffea   ebp: f75b1400   esp: ecdfddf4
ds: 007b   es: 007b   ss: 0068
Process runcbl (pid: 6003, threadinfo=ecdfd000 task=f5793210)
Stack: ecdfde54 c02b1888 f5793210 c011500c 00100100 00000137 01000004 ecdfde50
       00000340 f7c24938 ecdfde64 00000000 c01fdda4 ecdfde54 c01fdc8f f7dfcf58
       f75b1400 f7c249d0 ecdfdef0 ecdfded8 f7c249d8 00000010 f7c24938 f7dfcf58
Call Trace:
 [<c02b1888>] dlm_query+0x64/0x267
 [<c011500c>] default_wake_function+0x0/0x8
 [<c01fdda4>] get_conflict_global+0x10d/0x26c
 [<c01fdc8f>] query_ast+0x0/0x8
 [<c01fe0be>] lm_dlm_plock_get+0xb6/0xc2
 [<c0227595>] gfs_lock+0x289/0x31a
 [<c022730c>] gfs_lock+0x0/0x31a
 [<c015e0ee>] fcntl_getlk+0x15f/0x181
 [<c015a2af>] generic_file_fcntl+0xad/0x16b
 [<c015a47d>] sys_fcntl64+0x76/0x83
 [<c0103deb>] syscall_call+0x7/0xb
Code: f0 83 28 01 0f 88 df 00 00 00 89 d8 e8 07 fd ff ff f0 ff 43

Could any one help me?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/linux-cluster/attachments/20040625/78087191/attachment.htm>

More information about the Linux-cluster mailing list