[Linux-cluster] two fencing problems

Andrew C. Dingman adingman at cookgroup.com
Tue Dec 6 15:29:23 UTC 2005

At least in RHEL3, fence_apc only works with a very particular
configuration on the power strip. In particular, the numbers for menu
items change depending on whether the connecting user has permission to
do various things, so revoking permission to use outlets that aren't
part of your cluster will break the fencing agent. I ended up writing my
own fencing agent that was able to deal with at least a few more
configurations, though it's still not as flexible as I'd like.

My fencing agent is attached. I wrote it for RHEL3 and APC AP7901 power
strips, configured the way I wanted them, so it may or may not work for
you. Read the code. Test it somewhere it can't do any significant
damage. Don't come crying to me or my employer if it breaks. I disclaim
any responsibility for anything it might do, however heinous. Read and
understand the code before you use it. It's at least a start. It's not
as general as I'd like it to be, but since it works in the clusters I
wrote it for, I haven't been motivated to change it. It's derived from
the fencing agents Red Hat distributes, and therefore also under the

Once you've got that working for GFS, you can then set cluster suite to
use the Stonith bridge to fence through GFS, so you don't need to
explicitly configure the fencing device in system-config-cluster.

Hope that helps.

-Andrew C. Dingman
Unix Administrator
Cook Incorporated

On Mon, 2005-12-05 at 19:40 -0500, Greg Forte wrote:
> two (probably related) questions concerning fencing and APC AP7900 units:
> 1) fence_apc doesn't appear to be compatible with these units - when I run:
> sudo /sbin/fence_apc -a <ipaddy> -l <usr> -p <pwd> -n1 -T -v
> it comes back with:
> failed: unrecognised menu response
> The output file shows that it's getting as far as the "Outlet 
> Control/Configuration" menu, but never selects the specified port.
> This is on RHEL ES4 update 2 with fence-1.32.6-0 installed.
> Does anyone have this working with AP7900s, and if so did you have to 
> hack the fence_apc script or is there just something I'm missing?
>   2) in the cluster configuration tool (GUI), there's no place to 
> specify the port to cycle for an "APC Power Device".  I tried adding 
> "port=#" to the <fencedevice ...> tags in the cluster.conf file, but the 
> cluster configuration tool didn't like that.  And of course, I was 
> unable to test if this actually works anyway because of problem #1 :-(
> Anyway, assuming I get fence_apc to work, how do I specify ports in the 
> cluster configuration tool?  or is this not supported?  In which case 
> can I add the port option in the cluster.conf like I'm trying to do and 
> have it work?  I have system-config-cluster-1.0.16-1.0 installed.
> -g
> Greg Forte
> gforte at udel.edu
> IT - User Services
> University of Delaware
> 302-831-1982
> Newark, DE
> --
> Linux-cluster mailing list
> Linux-cluster at redhat.com
> https://www.redhat.com/mailman/listinfo/linux-cluster

More information about the Linux-cluster mailing list