[Linux-cluster] GFS and GFS2 : two questions: which is bettter; gfs_controld error

Ian Brown ianbrn at gmail.com
Sun Sep 2 08:04:23 UTC 2007

I had ran "modprobe gfs" and I see by lsmod the the gfs module is loaded.

also I had verified that under /lib/modules/MyKernelVersion/extra/gfs/ there is

Then I try:

gfs_mkfs -p lock_dlm -t myCLuster -j 32 /dev/cciss/c0d1p2
mount /dev/cciss/c0d1p2 /mnt/gfs

The errors I see in the console are:
/sbin/mount.gfs: lock_dlm_join: gfs_controld join error: -22
/sbin/mount.gfs: error mounting lockproto lock_dlm

The error I see in kernel log is:
gfs_controld[32629]: mount: not in default fence domain

I want to add that the cman service is started succesfully as the
kernel log shows.

I want also to add that "service cman start" performs modprbe of gfs2 module
and not gfs module !

Namely, I ran rmmod gfs; then, after :
service cman stop
rmmod lock_dlm
rmmod gfs2

running  lsmod | grep gfs2 shows that
no gfs2 is loaded,
and after "service cman start" I see by
 lsmod | grep gfs2
gfs2                  522965  1 lock_dlm

which means that starting the cman service performed modprobe/insmod
of gfs2 and lock_dlm

Is this how things should be?


On 9/1/07, Wendy Cheng <wcheng at redhat.com> wrote:
> Ian Brown wrote:
> >  - Hello,
> >   I had installed RHEL5 on two x86_64 machine on the same LAN; afterwards I
> >   had installed the RHEL5 cluster suite packege (cman-2.0.60-1.el5) and
> >   openais-0.80.2-1.el5.
> >
> >
> >   I had also installed kmod-gfs-0.1.16- and gfs-utils
> >and gfs2-utils.
> >
> >   I had crated a 2-node cluster and started the cman service OK on both nodes.
> >
> >   Now I tried to create a gfs partition with gfs_mkfs (with -p lock_dlm)
> >   and mount it, and I got errors when trying to mount it (this errors
> >talk about
> >   gfs_controld).
> >
> >
> You didn't include the error message here ? This could be a known issue
> where gfs kernel module is not loaded by default (due to a RPM
> dependency problem). To check it out: before mounting the gfs partition ...
> 1) shell> lsmod
> This is to check whether gfs (not gfs2) kernel module is loaded. If yes,
> mount the gfs partition, then read the /var/log/messages file and
> cut-and-paste the print-out (a.k.a the gfs_controld error messages) and
> repost here.
> 2) shell> cd /lib/modules/'your kernel version'/ extra/gfs
> Check if gfs.ko is there. If not, you have installation problems.
> 3)  shell> insmod gfs.ko
> This is to manually load gfs kernel module
> 4) Retry the mount. If still failing, send us the /var/log/messages file.
> >   I made a second try with mkfs.gfs2 (also with -p lock_dlm) );
> >   this time I **could** mounted the gfs2 partition succesfully.
> >
> >
> GFS2 is part of the base kernel, so it doesn't need to worry about RPM
> dependency.
> >   My questions are:
> >
> >     - should I be able with this installation to create and mount a gfs
> >     partition ? in case this is possible - what can be my mistale ?
> >
> >
> See above.
> >     - is gfs2 considered safe to work with ? or is it still experimental and
> >     not recommended ? which features do I have in GFS2 which I don't have in
> >     GFS?
> >
> >
> >
> The advantage of GFS2 are (my personal opinion - not necessarily Red
> Hat's) :
> 1. It is mainstream and will be well maintained and updated; vs. GFS
> starts to enter maintanence mode. We're hoping to phase out GFS as soon
> as GFS2 is proved to be stable.
> 2.  It preforms better (faster), particularly for smaller file size, but
> not as stable as GFS.
> However, there are tools to facilitate people to migrate from GFS to
> GFS2. So if you want stability, GFS is not a bad choice at this moment.
> -- Wendy
> --
> Linux-cluster mailing list
> Linux-cluster at redhat.com
> https://www.redhat.com/mailman/listinfo/linux-cluster

More information about the Linux-cluster mailing list