[Linux-cluster] Node will not join cluster.

Roger Peña orkcu at yahoo.com
Fri Sep 21 20:30:54 UTC 2007

--- Danny Wall <Danny.Wall at health-first.org> wrote:

> I have a two node cluster on RHEL4. It was all
> Update 4, but Red Hat suggested I update the problem
> node to U5, so now it is mixed.
> The problem:
> We had a SAN issue last week that took 3 of the 15
> LUNs offline. The SAN problem was been fixed, so I
> tried to rescan the LUNs, and still could not see
> the LUNs. 
after the restart, if booted in runlevel 1, did you
see the LUNs ?
I mean as normal sdX devices
for example:
fdisk -l /dev/sdf
give you the correct information?

>I restarted one node, and ever since then,
> it would fail when trying to join the cluster. I
> disabled the cluster services at boot, and try them
> manually. Every time I get to CLVMD, it hangs
> forever. Sometimes I can CTRL-C to break out,
> sometimes no. There are no relevant messages in
> /var/log/messages. I have worked with Red Hat and
> the last thing they suggested was to upgrade the
> node to U5. I did Tuesday, and it still hangs. I am
> afraid to take down the other node, because if it
> does the same thing, I am going to have major
> problems.

well,  you have a _two_ node cluster, so, you will
have always one node up, right?
if the LUNs are see it by the OS (kernel)

> I have also noticed that running lvdisplay,
> vgdisplay and pvdisplay hang. I am sure it is
> related. I know dlm and module is loaded.

I guess it is a matter of lvm unable to read the LUNs,
"initializated" the VG and LV

but, what about fencing and quorum of the cluster, are
they ok? 
or the node never go over the clvmd start and stay in
that stage forever?


RedHat Certified ( RHCE )
Cisco Certified ( CCNA & CCDA )

Pinpoint customers who are looking for what you sell. 

More information about the Linux-cluster mailing list