[Linux-cluster] gfs 6.1 superblock backups

Chris Adams cma at analog.org
Tue Jun 3 18:27:13 UTC 2008

Bob and Wendy, 
Thank you for your input on this.  What I am trying to do 
is upgrade a GFS 6.0 filesystems which are attached to various 
RHEL3/CentOS3 systems.  After performing the steps which outline the 
process of going from 3 to 4, but on a CentOS 5 system, I get the problems 
mentioned in my message yesterday Re: /sbin/mount.gfs thinks fs is gfs2?  
Everyt time I reinstalled a system with CentOS 5 and tried to get gfs 
running again I got the same error.

Since I know that this is an unsupported operation, I haven't sought 
support for this.  However, I noticed that my upgraded filesystem had 
sb_fs_format = 1308.  The mount code checks for sb_fs_format == 
GFS_FORMAT_FS for gfs 6.1 and GFS2_FORMAT_FS for gfs2.  Since it was 
neither of these, it kept dying saying that it was a gfs2 fs when mounting 
it as gfs, and vice versa.  Manually modifying sb_fs_format allowed it to 
mount immediately afterward.  A subsequent gfs_fsck completes all passes 

Is that sufficient for upgrading the filesystem if the other steps are 
performed?  All fs operations appear to be successful at this point.


More information about the Linux-cluster mailing list