[Linux-cluster] Can't create files bigger than 3864 bytes on GFS

Eric Gerlach egerlach at feds.uwaterloo.ca
Thu Sep 4 01:19:04 UTC 2008


I'm currently trying to set up GFS on a couple of Debian Testing boxes. 
  I've got the GFS setup and mounted, however I'm having trouble writing 
to files.  Using vi, cp, whatever.

If the file is up to 3864 bytes (one inode) it's fine.  But if I try to 
edit a file to make it bigger than that size, or copy in a file larger 
than that, the result is a zero byte file.

I've also tried doing GFS with the lock_nolock mechanism, and I get the 
same result.  The kernel is 2.6.26, and the Debian version of the tools 
is based off of cluster-2.03.06.  My filesystem is GFS, not GFS2.

Has anyone seen anything like this before?  I'm a newbie to GFS, so I'm 
not even sure where to start looking for an answer.  Even some help in 
that direction would be helpful.

Thanks in advance.


Eric Gerlach, Network Administrator
Federation of Students
University of Waterloo
p: (519) 888-4567 x36329
e: egerlach at feds.uwaterloo.ca

More information about the Linux-cluster mailing list