[Linux-cluster] Problem with shared storage and volume groups

Christine Caulfield ccaulfie at redhat.com
Wed Sep 17 16:09:46 UTC 2008

michael.osullivan at auckland.ac.nz wrote:
> Hi everyone,
> I have a shared storage device that my 2-node cluster can see
> (/dev/storage on both nodes). I wanted to set up a GFS system on the
> shared storage, but I am having problems getting both nodes to recognise a
> clustered volume group. To set up the clustered volume group I have used
> one of the cluster nodes (let's call it node 1).
> First, I created a physical volume on my storage device
> pvcreate /dev/storage
> Then I created a clustered volume group
> vgcreate -c y storage_vg /dev/storage
> However, when I run
> vgchange -aly
> on the other cluster node (node 2) I get an error stating that node 2
> can't find a volume group with the correct UUID. If I run vgscan and then
> vgchange -aly the error goes away, but node 2 still can't see storage_vg.
> I have also tried using conga without any success.
> Can anyone help? Please let me know if you need more info.
> Thanks, Mike

A full set of error messages from all the affected node would be
helpful. It's also worth doing a 'pvs' on each node to see if the PVs
are visible. Check which version of clvmd (and LVM) you have, some older
versions of clvmd need a restart if a new device is added.


More information about the Linux-cluster mailing list