[Linux-cluster] problem adding new node to an existing cluster

Greenseid, Joseph M. Joseph.Greenseid at ngc.com
Mon Jan 5 20:28:12 UTC 2009

---- "Joseph M. Greenseid" <Joseph.Greenseid at ngc.com> wrote:
| hi all,
| i am trying to add a new node to an existing 3 node GFS cluster.
| i followed the steps in the online docs for this, so i went onto the
| 1st node in my existing cluster, run system-config-cluster, added a
| new node and fence for it, then propagated that out to the existing
| nodes, and scp'd the cluster.conf file to the new node.
| at that point, i confirmed that multipath and mdadm config files were
| synced with my other nodes, the new node can properly see the SAN that
| they're all sharing, etc.
| i then started cman, which seemed to start without any trouble. i
| tried to start clvmd, but it says:
| Activating VGs: Skipping clustered volume group san01
| my VG is named "san01," so it can see the volume group, it just won't
| activate it for some reason. any ideas what i'm doing wrong?
| thanks,
| --Joe

> Hi Joe,

> Make sure that you have clvmd service running on the new node
> ("chkconfig clvmd on" and/or "service clvmd start" as necessary).

Hi Bob, 

Yes, this problem started when I tried to start clvmd (/sbin/service clvmd start).

> Also, make sure the lock_type is 2 (RHEL4/similar) or 3 (RHEL5/similar)
> in the /etc/lvm/lvm.conf file.

Ah, Ok, I believe this may be the trouble.  My lock_type was 1.  I'll change it and try again.  Thanks.


> Regards,

> Bob Peterson
> Red Hat GFS

-------------- next part --------------
A non-text attachment was scrubbed...
Name: winmail.dat
Type: application/ms-tnef
Size: 4399 bytes
Desc: not available
URL: <http://listman.redhat.com/archives/linux-cluster/attachments/20090105/6da60c4d/attachment.bin>

More information about the Linux-cluster mailing list