[Linux-cluster] Fencing Issues: fence_node fails but fence_ipmilan works

Manish Kathuria mkathuria at tuxtechnologies.co.in
Mon Jun 6 07:53:55 UTC 2011

I am facing a strange problem configuring a two node cluster using
RHCS 4.8. Both nodes are HP Proliant DL 180 G6 servers using HP LO
100i (IPMI Based).

When I run the fence_node command to check the fence device
configuration for either of the nodes, it fails giving the following
message in the logs:

fence_node[nnnn]: Fence of "node1" was unsuccessful
fence_node[nnnn]: Fence of "node2" was unsuccessful

However, when I run the fence_impilan command using the same
credentials, it executes successfully and is able to switch on, off
and reboot the nodes. The cluster configuration for the fence devices

IPMI Lan Type
Name:		lo1
IP Address:	172.16.1.x
Login		admin
Password	passone
Auth Type	password

Name:		lo2
IP Address:	172.16.1.y
Login		admin
Password	passtwo
Auth Type	password

I have already tried different options for Auth Type (blank, password,
md5). Have also tried using / not using lanplus for both the fence
devices in the Manage Fencing dialog without success.

Any suggestions ?


Manish Kathuria

More information about the Linux-cluster mailing list