[Linux-cluster] GFS2 daemon hangs during boot process

Karadeniz, Ercan, VF-Group ercan.karadeniz at vodafone.com
Sun May 1 21:57:23 UTC 2011

Hi Linux-Cluster-List-Members,


I'm a newbie in RHCS. I have visited recently the RH436 training. Currently I'm trying to get more experience by doing some hands-on on the course labs.


My setup is as follows:

·         Physical Server where Dom-0 is running

·         2 x xen virtual machines

·         2 nodes cluster (via Conga)


The two node cluster is setup by using Conga. The node1 and node2 are xen virtual machines. Everything worked so far. For fencing I'm using fence_xvmd. That is also working without any problems. 

To test the multicasting with different address (than the default one), I have done some changes on the multicast address and rebooted both nodes. Apparently when I start node1 or node2 (xm console node1 -c ) they hang during boot process on the "GFS2 daemon".

I have tried to login via using the "Single" mode as boot parameter regrettably this didn't help.


My question is how can I overcome this deadlock situation. I need somehow to boot both nodes and change my recent changes related to the multicasting address in the cluster.conf file. However I cannot login to any of the nodes? Furthermore is there a change within the xen virtual machine to get in to the interactive boot mode?


It would be great if you can give me some hint here.


Many thanks in advance!


Warm regards from Düsseldorf/Germany


Ercan Karadeniz



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/linux-cluster/attachments/20110501/209ef499/attachment.htm>

More information about the Linux-cluster mailing list