[Linux-cluster] GFS2 daemon hangs during boot process

Karadeniz, Ercan, VF-Group ercan.karadeniz at vodafone.com
Mon May 2 11:35:27 UTC 2011

Many thanks for the hints.


-----Original Message-----
From: Digimer [mailto:linux at alteeve.com] 
Sent: Montag, 2. Mai 2011 00:09
To: linux clustering
Cc: Karadeniz, Ercan, VF-Group
Subject: Re: [Linux-cluster] GFS2 daemon hangs during boot process

On 05/01/2011 05:57 PM, Karadeniz, Ercan, VF-Group wrote:
> Hi Linux-Cluster-List-Members,
> I'm a newbie in RHCS. I have visited recently the RH436 training.
> Currently I'm trying to get more experience by doing some hands-on on 
> the course labs.
> My setup is as follows:
> *         Physical Server where Dom-0 is running
> *         2 x xen virtual machines
> *         2 nodes cluster (via Conga)
> The two node cluster is setup by using Conga. The node1 and node2 are 
> xen virtual machines. Everything worked so far. For fencing I'm using 
> fence_xvmd. That is also working without any problems.
> To test the multicasting with different address (than the default 
> one), I have done some changes on the multicast address and rebooted 
> both nodes. Apparently when I start node1 or node2 (xm console node1 
> -c ) they hang during boot process on the "GFS2 daemon".
> I have tried to login via using the "Single" mode as boot parameter 
> regrettably this didn't help.
> My question is how can I overcome this deadlock situation. I need 
> somehow to boot both nodes and change my recent changes related to the

> multicasting address in the cluster.conf file. However I cannot login 
> to any of the nodes? Furthermore is there a change within the xen 
> virtual machine to get in to the interactive boot mode?
> It would be great if you can give me some hint here.
> Many thanks in advance!

You could try booting the VM using the RHEL5 ISO as the first boot
device, then boot into rescue mode. This should allow you to mount the
system and edit you /etc/fstab and/or /etc/cluster/cluster.conf.

As a side note, for testing, I like to 'chkconfig cman off'. This way, I
know that even if I totally screw up, I'll always be able to boot into
the host OS. :)

Further, I'd set the GFS2 entry in fstab to not use 'defaults', but
instead to use 'rw,suid,dev,exec,nouser,async'. This excludes the 'auto'
option, so that a failure to mount the GFS2 partition won't cause dom0
to drop to single-user mode.

E-Mail: digimer at alteeve.com
AN!Whitepapers: http://alteeve.com
Node Assassin:  http://nodeassassin.org

More information about the Linux-cluster mailing list