[Linux-cluster] Panic'ing rhel6 with 'echo c > /proc/sysrq-trigger' no longer stops the guest CPU, so recovery doesn't occur.

Digimer lists at alteeve.ca
Tue Dec 17 20:58:10 UTC 2013

Hi all,

  In previous configs, I knew that I could panic a RHEL/CentOS KVM VM
with 'echo c > /proc/sysrq-trigger' and the guest would halt entirely,
allowing vm.sh/rgmanager to detect the fault and reboot the guest.

  Now though, when trying it again recently, I noticed that the guest's
CPU sat pegged at 50% (2 vcpus, so probably one core pegged). This seems
to have prevented the failure from being detected, so the system was not

  Following here:


  I tried; 'echo 1 > /proc/sys/kernel/sysrq', I tried with selinux in
permissive and enforcing mode and I tried with RHEL 6.4 and 6.5. In all
cases, the guest's vcpu stayed active and rgmanager was unable to detect
the fault.

  I know that I can set; 'echo 5 > /proc/sys/kernel/panic' and have RHEL
auto-reboot post panic, but I'd like to know if it's possible to have
rgmanager actually detect the crash when this is not configured. Is
there a way to tell RHEL specifically/Linux in general to cease all
activity when it panic's?


Papers and Projects: https://alteeve.ca/w/
What if the cure for cancer is trapped in the mind of a person without
access to education?

More information about the Linux-cluster mailing list