[Linux-cluster] GFS2 filesystem consistency error

Bob Peterson rpeterso at redhat.com
Mon Feb 15 13:42:45 UTC 2016

----- Original Message -----
> Hello,
> We run some troubles since several days on our GFS2 (log attached):
> - we ran the FS for some times without troubles (since 2014-11-03)
> - the FS was grown from 3To to 4To near 6 month ago
> - it seems to happen only on one node “nebula3”
> - I run an FSCK when just fencing the node was not sufficient (2 crashes
>   the same day)
> The nodes run on Ubuntu Trusty Thar up to date.
> Do you have any idea?
> Regards.
> --
> Daniel Dehennin
> Récupérer ma clef GPG: gpg --recv-keys 0xCC1E9E5B7A6FE2DF
> Fingerprint: 3E69 014E 5C23 50E8 9ED6  2AAD CC1E 9E5B 7A6F E2DF

Hi Daniel,

As Steve mentioned, this means it tried to free a block that was already free.
The problem might be due to timing issues with regard to changing blocks
from "unlinked" state to "free" state. I have a number of patches required
to fix this, but some of them are not even in the upstream kernel yet.
And there is no guarantee this is the cause or solution for your problem.

As for fixing the file system: Newer versions of fsck.gfs2 should be able to
fix the file system. If it doesn't fix the file system, perhaps I could
get a copy of your file system metadata (via "gfs2_edit savemeta") and I
can see where it's failing. There are some known problems with fsck.gfs2 not
being able to correctly repair file systems that have been grown with gfs2_grow.
I've got fixes for that too, but it is all experimental code and none have gone
upstream yet. Your metadata might help me test it. :)


Bob Peterson
Red Hat File Systems

More information about the Linux-cluster mailing list