[linux-lvm] 0.8i --> 0.8final

Heinz Mauelshagen mauelsha at ez-darmstadt.telekom.de
Mon Mar 20 11:31:08 UTC 2000

> Hi
> I tried to migrate my system (currently running 2.2.14 / 0.8i with devfs)
> to 2.3.99-pre1 with the lvm patch applied. I built the new user space
> tools and copied the new vgscan and vgchange and liblvm.so to my initrd
> image (as i'm using root on LVM) and tried to boot. It failed as the
> vgscan reported no volume groups! I was unable to debug further as I can't
> boot into anything using this new kernel now - so i've reverted to 2.2.14.
> Any ideas?

The new lib uses /proc/partitions to figure out the existing block devices
by default.

Did you create your initrd file with the new lvmcreate_initrd, which
takes care of mounting /proc?

> CHeers!
> James



Systemmanagement CS-TS                           T-Nova
                                                 Entwicklungszentrum Darmstadt
Heinz Mauelshagen                                Otto-Roehm-Strasse 71c
Senior Systems Engineer                          Postfach 10 05 41
                                                 64205 Darmstadt
mge at EZ-Darmstadt.Telekom.de                      Germany
                                                 +49 6151 886-425

More information about the linux-lvm mailing list