[linux-lvm] pvcreate fails with invalid partition type.

Mark Jeffery markj at reading.sgi.com
Wed Nov 22 13:24:33 UTC 2000


I am trying to use LVM on an array of 8 SCSI disks with a 2.4 kernel and

I run fdisk on each disk, and create a new primary partition (1) for the
whole disk.

I then set the type to 0x8e

When I run pvcreate, it fails. Here is the text:

[root at kryten 0.8final]# pvcreate /dev/scsi/host1/bus0/target*/lun0/part1

pvcreate -- invalid partition type 0x42 for
"/dev/scsi/host1/bus0/target10/lun0/part1" (must be 0x8e)

I'm also showing the output from fdisk to "prove" that the disk id
really is 0x8e.

[root at kryten 0.8final]# fdisk -l

Disk /dev/scsi/host1/bus0/target10/lun0/part1: 255 heads, 63 sectors,
2212 cylinders
Units = cylinders of 16065 * 512 bytes

                                    Device Boot    Start       End
Blocks   Id  System
/dev/scsi/host1/bus0/target10/lun0/part1p1             1      2212
17767858+  8e  Unknown

Is this a problem with devfs and lvm?

Is there a workaround?


Mark Jeffery                Tel: +44 118 925 7666
Presales Analyst            Mob: +44 410 579828
SGI                         Fax: +44 118 925 7699
Email: markj at sgi.com        http://www.sgi.com

More information about the linux-lvm mailing list