[linux-lvm] problems compiling andreas' 3.4 userland tools under test11-pre1

Patrick Michael Kane modus at pr.es.to
Thu Nov 9 03:32:32 UTC 2000

* Andreas Dilger (adilger at turbolinux.com) [001108 19:23]:
> Patrick Kane writes:
> > I'm trying to get the 0.8final-3.4 to compile under test11-pre1, with no
> > luck.  I get all sorts of gcc parse errors in linux/lvm.h and liblvm.h.
> > 
> > I've tried compiling the tools with and without Andreas' 2.4 patch.  It
> > fails both ways.
> The 2.4 patch you refer to is lvm-0.8final-2.4-kernel.diff?  Is it
> possible you applied it to /usr/src/linux-2.4*/include/linux/lvm.h but
> there isn't a symlink /usr/include/linux -> /usr/src/linux/include/linux
> (i.e. you are running Debian or something)?

No, test11-1 is definately living in /usr/src/linux and the symlinks from
/usr/include/linux point to the right spot.  All of the other third party
modules I need compile up fine, for what it's worth.

> Alternately, you can simply change linux/lvm.h to lib/lvm.h and it should
> compile.

This fixed it.  It may well be that I'm not fixing the rejection in the
final-2.4-kernel.diff file correctly.

Patrick Michael Kane
<modus at pr.es.to>

More information about the linux-lvm mailing list