[linux-lvm] Unable to boot using LVM for "/"

Charles Duffy cduffy at mvista.com
Mon Oct 9 21:23:42 UTC 2000

On Mon, Oct 09, 2000 at 03:28:22PM -0400, Les Hazelton wrote:
> I have been attempting to move my root partition to a logical volume and
> eliminate the current normal partition.  No luck.  I have read the
> lvmcreate_initrd man page found at 
> http://linux.msede.com/lvm/man/man2html.cgi?lvmcreate_initrd:8
> and followed those instructions but it doesn't work for me. I have tried
> two different versions of lilo (lilo- and the 0.21.6
> binaries from the lilo site) and get the same result from both.
> If I use grub with the menu.lst shown below I can boot the entry for
> linux-2 and the system runs correctly. Neither of the other two entries
> will boot correctly. The /dev/hda9 is the real partition I am attempting
> to eliminate.  If I try to boot the first, linux, entry it gets a kernel
> panic because it can't locate init. The third entry produces a kernel
> panic because it can't mound device 0:0

"root=/dev/vg01/main" fails because the kernel, when booting, just
determines the major/minor numbers for the root partition based on
looking up the root device in a fixed table. What you need to do to
get the "test" entry running is change the root to the major/minor
number combo in hex; in my case, where /dev/vg01/root has major/minor
number 58,3 in decimal, I pass "root=3a03" to grub and that works

Note that the above presumes that the initrd runs correctly. Does it?
(Be aware that I had to add /dev/console and /dev/tty0 entries to the
initrd to see output from the programs run from it... this may have
been fixed by now, or maybe not).

Hope this has been of some use.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 232 bytes
Desc: not available
URL: <http://listman.redhat.com/archives/linux-lvm/attachments/20001009/fbe2e30e/attachment.sig>

More information about the linux-lvm mailing list