[linux-lvm] Problems after upgrading LVM

Ulrich Wiederhold U.Wiederhold at gmx.net
Thu Dec 6 04:00:02 UTC 2001

try to use uuid_fixer on every pv you have in your vg.
Then do a "vgcfgrestore -n your_vgname -l" and if this works a 
"vgcfgrestore -n vg_name /dev/hdXX (for each pertitions in the VG)".
Run vgscan again, then vgchange -ay. I think this should work.
I prefered it to run vgcfgbackup after it´s done.
Btw, this was discussed the last mouth several time on this list,
searching in the archive would have been helped you. :)

* Klaus Agnoletti <ultra at mailme.dk> [011206 09:20]:
> I got my problem solved.
> It seems like I can't restore a vg created with an older version of LVM
> than the one I am currently using.
> This means that VGs in my stup created with LVM 0.9 can't be restored
> after upgrading to 1.0.1.
> Is this a bug ? (I would say yes) - if not, what is the correct
> procedure to get your VG up and running after an update ?
> I tried doing a 
> vgcfgrestore -n vg_name /dev/hdXX (for each pertitions in the VG)
> vgchange -ay
> And after that just a regular mount.
> After this discovery, my setup is debian linux with kernel 2.4.16 (which
> has lvm 1.0.1rc4) and the tools for lvm 0.9 which I originally created
> the vg with) - to me this sounds rather weird.
> What did I miss ?
> Thanks,
> Klaus Pedersen
> _______________________________________________
> linux-lvm mailing list
> linux-lvm at sistina.com
> http://lists.sistina.com/mailman/listinfo/linux-lvm
> read the LVM HOW-TO at http://www.sistina.com/lvm/Pages/howto.html
'The box said, 'Requires Windows 95 or better', so i installed Linux - TKK 5

More information about the linux-lvm mailing list