[linux-lvm] pvmove killed vg

gunther.kuhlmann at web.de gunther.kuhlmann at web.de
Tue Dec 11 15:32:02 UTC 2001


I've got a broken lvm vg as a result of an unsuccessful pvmove
command. My system is a SuSE 7.0 with kernel 2.4.4 and

The vg spans several partitions on one disks, one of which I 
wanted to evacuate. I used the pvmove command with chunks of 
32 PE (= 1 GB); 10 GB total. The first 8 chunks worked okay,
but the 9th (pvmove -v /dev/hda8:256-287 /dev/hda10) fell over
with error code 23 while moving the fifth PE. So I checked using
pvdisplay that the four PE had indeed been moved. A further
attempt with pvmove -v /dev/hda8:260-287 /dev/hda10 fell over as
well, again error code 23. (That's error moving physical

I then rebooted the machine which killed the complete volume
group. Which in turn did not quite impress me. :-((

During my attempts at recovering I think I did a vgscan, which
found the vg "vg1" on /dev/hdb, but not the vg "vg0" on /dev/hda.

I tried the following commands unsuccessfully:
- vgcfgrestore -v -n vg0: please enter physical volume name (the
  synopsys of vgcfgrestore did not state it as a mandatory 
- vgcfgrestore -v -n vg0 /dev/hda10: can't restore part of active
volume grout vg0
- vgcfgrestore -v -n vg0 /dev/hda{6,7,8,10}: please enter physical
volume name
- vgchange -a n vg0: volume group vg0 does not exist
- vgchange -a y vg0: volume group vg0 does not exist

I still have the file /etc/lvmconf/vg0.conf.cd as well as the
devices /dev/vg0/lv0{0,1,2,3} and /dev/vg0/group. (And
/dev/vg1/..., but that is working.)

Any suggestions on how I can recover the data would be highly
appreciated. I found a reference to a program called
uuid_fixer/uuid_editor, but usage was discouraged. Do I have to 
try it
or is there a better way? Does upgrading to a newer version of lvm
help? Or do I have to update the kernel as well then? And I 
do _not_ want to kill my other vg as well.



Die schönsten Ski-Regionen der Alpen - jetzt bei Ferienklick.de

More information about the linux-lvm mailing list