[linux-lvm] Urgent, Please help LVM-krash

Erik Bågfors Erik.Bagfors at ardendo.se
Thu Dec 13 07:35:02 UTC 2001

Hi all!

Yesterday I krashed my lvm.  This is the first time I'm having real
problems with it.

This is what happened.

I was going to add a new lv and used the lvcreate-command as usual. 
This time I forgot the -n switch and when I realized that I hit ctrl-c..
BAD idea!

Now my vg is gone.  I can't get it back whatever I try.  Any help would
be VERY appreciated.

A vgscan just sais "no volume groups found" or something like that. 
doing a pvdisplay on the pv's in my vg gives me that they should be in
"diskvg" (which is correct).  I've tried doing vgcfgrestore from the
backups in /etc/lvmconf but that doesn't help.  vgscan still doesn't
find it.

I looked at the HOWTO and found a program named uuid_fixer that looked
like it could solve the problem but it died with an "illegal
instruction" regardless of if I used the precompiled version or compiled
it myself.

This is on a mandrake 8.1-box with lvm, xfs, reiserfs and devfs so there
are alot of things to think about.

When doing stuff I did the following first:
 reboot into single user, remount / rw, mount /proc, restore some
standar-stuff into /dev, and start devfsd

After that I tried vgcfgrestore, vgscan, uuid_fixer and just about
everything I could think or.

Please please please help me.  Can anyone solve this.  There are over 60
GB of stuff on this computer and it needs to work TODAY :(


Erik Bågfors               | http://www.ardendo.se/
Erik.Bagfors at ardendo.se    | GSM +46 733 279 273
fingerprint: 6666 A85B 95D3 D26B 296B 6C60 4F32 2C0B 693D 6E32

More information about the linux-lvm mailing list