[linux-lvm] Urgent, Please help LVM-krash

Erik Bågfors erik at bagfors.nu
Mon Dec 17 05:40:01 UTC 2001

mån 2001-12-17 klockan 12.22 skrev Heinz J . Mauelshagen:
> On Thu, Dec 13, 2001 at 02:37:04PM +0100, Erik Bågfors wrote:
> > Hi all!
> > 
> > Yesterday I krashed my lvm.  This is the first time I'm having real
> > problems with it.
> > 
> > This is what happened.
> > 
> > I was going to add a new lv and used the lvcreate-command as usual. 
> > This time I forgot the -n switch and when I realized that I hit ctrl-c..
> > BAD idea!
> Erik,
> that's actually starneg, because the tools intercept ctrl-c and the like :-(

Hmm.. well .. it did break the program for me..  Maybe it's an old
version with mandrake 8.1??

I know that the kernel lvm-stuff is NOT the latest version.  Is it ok to
run an old version or do I risk damage to the system??
> > Now my vg is gone.  I can't get it back whatever I try.  Any help would
> > be VERY appreciated.
> > 
> > A vgscan just sais "no volume groups found" or something like that. 
> > doing a pvdisplay on the pv's in my vg gives me that they should be in
> > "diskvg" (which is correct).  I've tried doing vgcfgrestore from the
> > backups in /etc/lvmconf but that doesn't help.  vgscan still doesn't
> > find it.
> Did you run "pvcreate -ff" on all of your PVs belonging to diskvg *before*
> you run vgcfgrestore on all of them?  vgscan afetrwards.

At first I didn't, but I tried that later.  Same thing.
> > 
> > I looked at the HOWTO and found a program named uuid_fixer that looked
> > like it could solve the problem but it died with an "illegal
> > instruction" regardless of if I used the precompiled version or compiled
> > it myself.
> > 
> > This is on a mandrake 8.1-box with lvm, xfs, reiserfs and devfs so there
> > are alot of things to think about.
> > 
> > When doing stuff I did the following first:
> >  reboot into single user, remount / rw, mount /proc, restore some
> > standar-stuff into /dev, and start devfsd
> > 
> > After that I tried vgcfgrestore, vgscan, uuid_fixer and just about
> > everything I could think or.
> I think it was just the lack of pvcreate before vgcfgrestore.


But I think there was another problem. I've had a few small problems
with xfs under mandrake 8.1.  Sometimes I've lost some files.  I really
don't know why but the data in them have been corrupted or they were 0
bytes in size.  I have been really mean to the computer and killing the
power on it while it was running and so on. But that was never a problem
under reiserfs so I'm back with 100% reiserfs now.  I think the files in
/etc/lvmconf were strange.
> > 
> > Please please please help me.  Can anyone solve this.  There are over 60
> > GB of stuff on this computer and it needs to work TODAY :(
> >

Like I said I needed that computer back the same day.  I ended up
reinstalling the box.  Loosing the data I had on it.  Luckily most data
was either not important or could be restored from backup. The only
thing I really lost was the system with all it's services and the like. 
So I guess I need to resetup samba/appleshare/web/nfs/dns and so on.  

Erik Bågfors               | erik at bagfors.nu
Supporter of free software | GSM +46 733 279 273
fingerprint: 6666 A85B 95D3 D26B 296B 6C60 4F32 2C0B 693D 6E32

More information about the linux-lvm mailing list