[linux-lvm] LVM Boot = /sbin/modprobe: error while loading shared libraries: libzso.1

Ben Holness ben at bens-house.org.uk
Wed Dec 26 19:28:02 UTC 2001

>> did you run lilo again after creatinh the initrd?
> <sheepish grin> No </sheepish grin>
> OK, ran lilo and it got back to stage one again - cannot open
> libz.so.1
> (error exactly the same as per my first LVM root mail) :(

And having looked around a bit more, I discovered that the newer version
creates an image in /boot that is not called initrd :)

So I changed /boot/lilo.conf to reflect the new boot image and tried again.

This time the image decompresses OK and then I get:


VFS: Mounted root (ext2 filesystem)
VFS: Cannot open root device "3a01" or 3a:01
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 3a:01


> I had some trouble with pvcreate because MDK set my system up with devfs
> enabled.

> Could this be playing some part in the problem?

I should also mention that I ran lvmcreate_initrd with the -D option, but
that didn't help.



More information about the linux-lvm mailing list