[linux-lvm] pvmove error......and now I have no VG :(

Glenn Shannon warl0k at lvcm.com
Sat Mar 9 18:18:02 UTC 2002

Ah ha!

Nevermind....figured it out I think.

All I did was upgrade from 1.0.1-rc4 to 1.0.3 (figured the newer tools might have some better error handling) and then did a vgcfgrestore to all the partitions/new disk and then ran vgscan and *bam* it's back in business!

Thanks all!

  ----- Original Message ----- 
  From: Glenn Shannon 
  To: linux-lvm at sistina.com 
  Sent: Saturday, March 09, 2002 5:03 PM
  Subject: [linux-lvm] pvmove error......and now I have no VG :(

  Hi Everyone!

  I just installed a new 60G hard drive that I bought, tried to follow section 16 of the HOWTO on the sistina website to move the data from a 13G hard drive to the new 60G hard drive.

  During the vgreduce it segfaulted, and now my entire VG has disappeared *gasp*.

  What do I do now? I tried to look up how to recover from such a situation but alas, no dice.

  Any and all help is appreciated!

  long live LVM!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/linux-lvm/attachments/20020309/431c6ee9/attachment.htm>

More information about the linux-lvm mailing list