[linux-lvm] help with redhat install

Ed Jackson ej_external at bigfoot.com
Wed Mar 13 22:04:03 UTC 2002

I'm trying to install and use LVM on my redhat - but I'm having 
difficulties getting started.

I've tried to download and use the binaries at ftp.msede.com:


and also all of the following files in:



When I install all of those RPMs with gnorpm, and try to run the wrapped 
shell scripts for anything to do with LVM (like pvcreate) I get an error 
message stating:

-------------- sample message --------------
lvmiopversion -- LVM driver/module not loaded?

vgcreate: /lib/lvm-iop not found.  Is lvm-iop installed?

And when I search the current filesystem for anything named *lvm-iop* I get 

I have added the following to /etc/modules.conf

alias block-major-58 lvm-mod
alias char-major-109 lvm-mod

Since that didn't seem to work - I removed those RPMs and tried to download 
the latest from ftp://ftp.sistina.com/pub/LVM/1.0/ and unpacked all 
files.  When I follow the instructions in the lvm-howto doc.. I run 
LVM/1.0.1-rc4/configure script, which seems to complete fine.

I then cd into PATCHES and try to run 'make' and get the following error:

You haven't applied the rawio patch, please see the README
make: *** [check_rawio] Error 1

The README file only discusses the raw_io patch if I'm using a 2.2 
kernel.  But i'm currently using 2.4.9-31

Can anyone please help me out with this?  I'd like to just use the RPMs if 
possible - and the source code next if the RPMs don't work out.

Thanks, Ed

More information about the linux-lvm mailing list