[linux-lvm] vgchange -- ERROR "parameter error"

Gayatri Prabhu gayatri_prabhu at yahoo.com
Fri Nov 1 14:16:02 UTC 2002


I read a few emails on this mailing list with the same
problem. I'm using LVM version 1.0.1-rc4, kernel
2.4.7, Redhat 7.2. I've been unable to activate a VG
since yesterday. I've been trying to recover data from
the VG using  the "pvcreate, vgcfgrestore, vgscan,
vgchange" procedure given as a solution to this
problem. I still get the following error:
vgchange -- ERROR "parameter error" setting up
snapshot copy on write exception table for

I've tried using all the old config files for this VG
in /etc/lvmconf, but even the oldest file has the
"messy" snapshot since the snapshot creation was being
done as part of an hourly cron job. 

I would appreciate it if you could let me know whether
there is any other way to still recover the data on
the disk ? Also, is there a later version of LVM in
which this problem has been fixed ?


Do you Yahoo!?
HotJobs - Search new jobs daily now

More information about the linux-lvm mailing list