[linux-lvm] strange behavior with 1.0.5 on Linux 2.4.19?

Gregory Ade gkade at bigbrother.net
Thu Nov 7 21:45:01 UTC 2002

On Tue, 2002-11-05 at 06:28, Heinz J . Mauelshagen wrote:

> > > If you have a chance to reconfigure the failing system temporarily,
> > > running what you did before should reproduce the same problems (segfault
> > > on snapshot creation after fresh reboot) in case there's _no_ bug in the
> > > large/high memory support.
> > > My assumption is that it will not.

> There's no need to physically remove any DIMMs. Just cook up a kernel
> without the patches you mentioned to get that elefant going and
> without high memory support.

Okay, I disabled high memory support (only change from production
kernel), rebooted with this test kernel, and tried to create a snapshot:

root at burpr(pts/0):~ 26 # lvcreate --snapshot --extents 512 --name
tmp_snap /dev/vg00/tmp
lvcreate -- INFO: using default snapshot chunk size of 64 KB for
lvcreate -- doing automatic backup of "vg00"
lvcreate -- logical volume "/dev/vg00/tmp_snap" successfully created

It worked just fine:

root at burpr(pts/1):log 28 # lvdisplay /dev/vg00/tmp
--- Logical volume ---
LV Name                /dev/vg00/tmp
VG Name                vg00
LV Write Access        read/write
LV snapshot status     source of
                       /dev/vg00/tmp_snap [active]
LV Status              available
LV #                   2
# open                 1
LV Size                2 GB
Current LE             512
Allocated LE           512
Allocation             next free
Read ahead sectors     120
Block device           58:1

So I removed it:

root at burpr(pts/1):log 29 # lvremove /dev/vg00/tmp_snap
lvremove -- do you really want to remove "/dev/vg00/tmp_snap"? [y/n]: y
lvremove -- doing automatic backup of volume group "vg00"
lvremove -- logical volume "/dev/vg00/tmp_snap" successfully removed

No kernel oops or BUG in the dmesg.

Again, the _ONLY DIFFERENCE_ between this test kernel and the production
kernel is the high-memory support option.  On the test kernel, it is
off, and on the production kernel, it is set to 64GB.

Hope this helps.

Gregory K. Ade <gkade at bigbrother.net>
OpenPGP Key ID: EAF4844B  keyserver: pgpkeys.mit.edu
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 232 bytes
Desc: This is a digitally signed message part
URL: <http://listman.redhat.com/archives/linux-lvm/attachments/20021107/c89d0f62/attachment.sig>

More information about the linux-lvm mailing list