[linux-lvm] Re: LVM and mounting

Kenny Gorman kgorman at backflip.com
Tue Nov 19 15:56:01 UTC 2002

Just to add to this (I am not sure if this hit the list anyways, I just 

I am running SuSE 2.4.16-64GB, and lvm 1.0.<something, can't get on the 
box to verify at this point...>


Kenny Gorman wrote:
> I am having a problem where when I boot up the machine, the machine says 
> I need to fsck one of my logical volumes.  This volume I just added a 
> new filesystem to, but it hung on mount, so I rebooted.  Then I tried to 
>  lvremove the volume, and it says it successfully removed it, then I am 
> running vgchange -a n <grp> and vgremove <grp>.  But it says I can't 
> remove the group.. because it belongs to a volume.
> I think my lvmtab or someting is all messed up because the some messages 
> seem to indicate that the volume is there, and some say it's not. 
> lvdisplay says it does not exist.
> I would just like to remove the entire volume and group and start over 
> so I can get my machine to boot.  Is there some option to just 'ignore' 
> or 'force' destroy the volume?  If I fdisk the disk will I still get 
> this error?
> Any help would be great!!
> thx
> -kg

More information about the linux-lvm mailing list