[linux-lvm] lvm/devfs bug?

rich turner rich at storix.com
Thu Apr 10 16:10:02 UTC 2003

i have tried to clear partition table with:

i have tried many different things:
# dd if=/dev/zero of=/dev/sda bs=1024 count=10
# blockdev --rereadpt /dev/sda

# sfdisk -R /dev/sda1

following these commands /proc/partitions does not show a partition on
sda but pvcreate complains that there is.

if this is a bug then how do i submit it?

On Thu, 2003-04-10 at 12:58, Kevin P. Fleming wrote:
> rich turner wrote:
> > does anyone recognize this as a bug within lvm?
> > 
> > there clearly is not a partition on sda (according to /proc/partitions)
> > but pvcreate thinks there is one. if pvcreate examines only
> > /proc/partitions for disk partitions and there is not a partition on a
> > disk then why does pvcreate fail? i may not understand all of the
> > underlying behavior of pvcreate but it appears to be failing when it
> > shouldnt. is this a bug?
> > 
> If I remember your original message properly, the error you got from pvcreate 
> was that the disk "contained a partition table". This is _not_ the same thing as 
> the disk containing one or more partitions; there can very well be an empty 
> partition table on the disk. This may not be the problem, but if it is, using
> dd if=/dev/zero of=/dev/sda count=20
> will wipe out any existing DOS-type partition table (or any other type of table 
> that resides at the beginning of the disk). If you've already tried this, then 
> I'd say there is definitely a bug happening.
> _______________________________________________
> linux-lvm mailing list
> linux-lvm at sistina.com
> http://lists.sistina.com/mailman/listinfo/linux-lvm
> read the LVM HOW-TO at http://tldp.org/HOWTO/LVM-HOWTO/

More information about the linux-lvm mailing list