[linux-lvm] problem building LVM2 for 2.6 kernel

Robert P. J. Day rpjday at mindspring.com
Fri Jul 18 16:04:02 UTC 2003

  in trying to set up LVM for the 2.6 kernel, i configured the
2.6.0-test1-ac2 version and selected device mapper and v4 ioctl
(this version of the kernel did not appear to need any patching),
rebuilt, and rebooted with the new kernel, and that seemed to go

  i then built and installed libdevmapper (the latest version
from today), and that again went smoothly.

  but when i tried to build the final LVM2 utilities, i ran

  # ./configure --with-lvm1=none
  # make

 which eventually produced:


device/dev-io.c: In function `dev_get_size':
device/dev-io.c:215: `BLKGETSIZE64' undeclared (first use in this function)
device/dev-io.c:215: (Each undeclared identifier is reported only once
device/dev-io.c:215: for each function it appears in.)
make[1]: *** [device/dev-io.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make: *** [lib] Error 2

  is there something i did wrong?  a patch i forgot to install?


More information about the linux-lvm mailing list