[linux-lvm] Broken UUID, and maybe more?

David Röhr david at rohr.se
Sat Jul 19 10:55:01 UTC 2003

I had a crash on my system today, and when booting my PV:s had gotten
corrupt. When checking the UUID on the disks it seems that they where a
bit strange, and somewhat missing.

I tried the uuid_fixer, and also tried some stuff with dd, the script
says success, and even with the debug on it says ok.

But when checking with pvdisplay the problem still is there.

It seems to get the right information some times, when doing pvdisplay a
couple of times I get the right info, the wrong info, and sometimes, 

pvdisplay -- ERROR "pv_check_consistency(): PE size" checking
consistency of physical volume "/dev/hdj"

Is ther any way to fix this? I don't want to lose all my data on the
disks, so now I'm hoping there is something I can do?

When running vgscan I always get..

vgscan -- ERROR "pv_read_all_pv_of_vg(): no PV" can't get data of volume

Can't realy see that several of my disks get broken at the same time?


... david röhr              |      o_
.. unix systems consultant  | o/  /\   Solaris, AIX, HP-UX
. qbranch system management | /|_, \\   and GNU/Linux Certified.
        www.qbranch.se        /                    

More information about the linux-lvm mailing list