[linux-lvm] Problems with snapshots on sparc64

Daniel Bayer daniel.bayer at stud.uni-rostock.de
Thu May 29 07:09:18 UTC 2003


I have a E250 running Debian/stable with Linux 2.4.20 (vanilla kernel,
except for xfs). Three weeks ago I created a LV with an xfs on it. I
also created a backupscript that uses snapshots. For two weeks
everything worked fine.

Then I got oopses during the backup (mainly from kupdated). After that
the system was rebooted. I had to boot with init=/bin/sh since the
system freezed while mounting the xfs partitions (another story). I
did a vgscan and a vgchange. After that I did a
"lvdisplay /dev/vg1/lv_snapshot" and got the usual output and 3 times
the error "Trying to vfree() nonexistent vm area (addr)". Then I tried
"lvdisplay /dev/vg1/lv" and also got the vfree()-error and a
Segmention-Fault after the line that says that there is a snapshot of
this LV. I removed the snapshot and "lvdisplay /dev/vg1/lv" worked
fine. After that I could bring the whole system in a working state.
I could reproduce this.

The address in the vfree()-error message only changes after a reboot.
I also found older vfree()-errors in the log.

The Backtrace of the oops always ends in
| Trace; 005143e8 <lvm_map+488/580>
| Trace; 005144e8 <lvm_make_request_fn+8/40>

Another related problem is, that "cat /proc/lvm/global" in the most
cases doesn't output the usual data but some random memory. Its really
odd. But if I try often enough I sometimes also get the right output
(and no, I didn't calculated the probability). The other files in
/proc/lvm work fine.

Since I moved the important stuff to another system I can do some
tests and provide further informations.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://listman.redhat.com/archives/linux-lvm/attachments/20030529/30f05348/attachment.sig>

More information about the linux-lvm mailing list