[linux-lvm] vgreduce fails

Spam spam at tnonline.net
Fri Nov 7 04:54:02 UTC 2003

  Yes  I tried that way too. I had tried restarting the system with no
  luck  too.  But  when  I  changed to LVM2 it worked fine without any
  problems.  I  have  no  idea what was wrong. I tried to move several
  different disks and all gave the same error with LVM1.

> Have you tried removing the one free PV rather than using "-a" ?
> Have you run vgck to check volume group consistency ?
> Does the machine have an extraordinary long uptime ?

> On Mon, Nov 03, 2003 at 04:40:44AM +0100, Spam wrote:
>>   I am trying to reduce a physical volume from my VG "Server" but
>>   when I get to the step "vgreduce" it fails with this error:
>>   vgreduce -- ERROR "parameter error" reducing volume group
>> "Server" by physical volume
>> "/dev/ide/host2/bus0/target0/lun0/part1" in kernel
>>   There is a logfile and debug output on http://tnonline.net/lvm.txt
>>   (also attached as lvm.zip).
>>   I am using Gentoo Linux, but tried with vanilla kernel 2.4.22 and
>>   lvm tools 1.0.7.

More information about the linux-lvm mailing list