[linux-lvm] pvscan cant find my volume..

Hjalmar Wåhlander grazzy at quake.swe.net
Tue Nov 11 16:00:09 UTC 2003

As stated in a eariler message, I also tried this:

[root at mircosoft /mnt]# cp /etc/lvmconf/the_data.conf /etc/lvmtab.d/the_data
[root at mircosoft /mnt]# echo -ne "the_data\0" > /etc/lvmtab
[root at mircosoft /mnt]# vgchange -ay the_data
vgchange -- ERROR: physical volume "/dev/hdc" of volume group "the_data" is 
vgchange -- run vgscan

At 22:49 2003-11-11, you wrote:
>This started out when I rebooted my machine. Prior to the reboot I ran 
>fsck on the lvm-filesystem and got quite alot of errors.
>My vg contains three hdds:
>hdc, hde and hdf.
>[root at mircosoft /mnt]# vgscan
>vgscan -- reading all physical volumes (this may take a while...)
>vgscan -- ERROR "vg_read_with_pv_and_lv(): current PV" can't get data of 
>volume group "the_data" from physical volume(s)
>vgscan -- "/etc/lvmtab" and "/etc/lvmtab.d" successfully created
>vgscan -- WARNING: This program does not do a VGDA backup of your volume group
>This error I've seen quite a few times in this list, however, as many 
>replies are suggesting - running "pvcreate -ff" - does not help.
>[root at mircosoft /mnt]# pvcreate -ff /dev/hdc
>pvcreate -- device "/dev/hdc" has a partition table
>And, to my surprise, dmesg, reports that hdc has a hdc1 (not that I can 
>remember ever creating one... ), but anyway, how can I bypass this?
>Some extras:
>[root at mircosoft /mnt]# pvdisplay /dev/hdc
>pvdisplay -- no physical volume identifier on "/dev/hdc"
>(But it works fine on hde and hdf).
>Im very grateful for any help!
>linux-lvm mailing list
>linux-lvm at sistina.com
>read the LVM HOW-TO at http://tldp.org/HOWTO/LVM-HOWTO/

More information about the linux-lvm mailing list