[linux-lvm] vgcfgrestore and bootstrap

Gingia gingiabios at email.it
Wed Sep 24 07:23:01 UTC 2003

Alle 10:37, mercoledì 24 settembre 2003, Heinz J . Mauelshagen ha scritto:
> Gingia,
> the normal procedure is "vgscan ; vgchange -ay ; mount -a"
> rather than vgcfgrestore before vgchange.
> Have you tried "vgscan ; vgchange -ay ; mount -a" before ?
> (keep in mind, that vgscan needs space below /etc/ to store metadata
> copies)

I controlled the script of bootstrap  to see if there is the apropiated entry, 
and it seems is ok, i also re-started the server .
I  tried "vgscan" and i have the output:
invalidate :dirty buffer 
invalidate :busy buffer  
(any time)
vgscan -- "/etc/lvmtab" and  "7etc/lvmtab.d" successfully created 
vgscan -- WARNING: this programm doe not do a VGDA backup of your group

after i do :
vgchange -ay 
and the output was:
vgchange -- no volume group found 

so i made the restore:
vgcfgrestore .........
the ouptput was 
vgcfgrestore -- VGDA for "Volume1" successfully restored to phisical volume 
vgcfgrestore  -- you may not have an actual backup of restored group "volume1"

then i can do  vgchange -ay  and go on 

This is all , was it the matter?

Thank you

More information about the linux-lvm mailing list