[linux-lvm] recovering a lvm volume group after one partition's deletion

Òscar Álvarez Vilaplana grimborg at gmail.com
Tue Dec 7 18:47:57 UTC 2004


I've just found out that the reason I couldn't get my lvm volume group
to work was because I had accidentally formatted one of the partitions
that were used in that group, instead of the partition I actually
wanted to format. (I really should have rebooted when fdisk told me
to:( )

I've been trying to recover the information that was stored on the
volume group. Since the partition was only 1.88Gb big in a volume
group of 50Gb I thought maybe all was not lost.

What I've tried is running pvcreate on the formatted partition, but
vgdisplay complains that that it can't find the partition with the
uuid of the lost partition. I then tried hexedit'ing the partition and
changing its uuid, but this didn't fool lvm either: i got the same

Is there any way to bring back, not all, of course, but some of the
data in the volume group?



More information about the linux-lvm mailing list