[linux-lvm] recovering a lvm volume group after one partition's deletion

Òscar Álvarez Vilaplana grimborg at gmail.com
Tue Dec 7 19:56:14 UTC 2004


I did a pvcreate --restorefile thefile --uuid theuuid mygroup and then
vgcfgrestore thefile.

Now the logical volumes appear in /dev/mygroup/, but when I try to
mount them I get the error "mount: special device /mount/mygroup/myvol
does not exist"

I googled for an answer but I couldn't find anything relevant.

Any ideas?


On Tue, 7 Dec 2004 19:29:07 +0000, Alasdair G Kergon <agk at redhat.com> wrote:
> On Tue, Dec 07, 2004 at 07:47:57PM +0100, Òscar Álvarez Vilaplana wrote:
> > What I've tried is running pvcreate on the formatted partition, but
> > vgdisplay complains that that it can't find the partition with the
> > uuid of the lost partition. I then tried hexedit'ing the partition and
> > changing its uuid, but this didn't fool lvm either: i got the same
> > error.
> man vgcfgrestore
> Alasdair
> --
> agk at redhat.com
> _______________________________________________
> linux-lvm mailing list
> linux-lvm at redhat.com
> https://www.redhat.com/mailman/listinfo/linux-lvm
> read the LVM HOW-TO at http://tldp.org/HOWTO/LVM-HOWTO/

More information about the linux-lvm mailing list